summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-09-03 14:08:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-04 23:10:13 +0200
commit3c48ef60ad8fa76075e0fc72bd0dba7f09366915 (patch)
tree44309c3fb000e54eef169d1a9e177e826c2b3af3 /gnu
parented24d6b46cc0f4ff32c3f285e9bb42a319c6f8ca (diff)
gnu: hashcat: Don't embed timestamp, fixing reproducibility.
* gnu/packages/password-utils.scm (hashcat)[arguments]{#:phases}: Remove timestamp, fixing reproducibility. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index e8c3feaeba..1228c42297 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -35,6 +35,7 @@
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1126,6 +1127,11 @@ your online accounts makes it necessary.")
'(#:tests? #f ;no tests
#:make-flags (list (string-append "PREFIX=" %output))
#:phases (modify-phases %standard-phases
+ ;; Don't embed timestamps, for bit-for-bit reproducibility.
+ (add-after 'unpack 'fix-reproducibility
+ (lambda _
+ (substitute* "src/Makefile"
+ (("\\$\\(shell date \\+%s\\)") "0"))))
(delete 'configure))))
(home-page "https://hashcat.net/hashcat/")
(synopsis "Advanced password recovery utility")