summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2023-02-15 23:00:15 +0100
committerChristopher Baines <mail@cbaines.net>2023-02-17 15:44:57 +0000
commit3f84fbd2f17b3907f35492ab93765c8ad2760801 (patch)
tree60424e83e063269347b81d442d0f37486d5343a7 /gnu
parent419023489e9ba39cf115fcdfbdbc109633bf09c9 (diff)
gnu: Add ocaml-async-unix.
* gnu/packages/ocaml.scm (ocaml-async-unix): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 304c900af5..4333782f86 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -8413,6 +8413,32 @@ core_kernel.")
JavaScript using @code{Async_js}.")
(license license:expat)))
+(define-public ocaml-async-unix
+ (package
+ (name "ocaml-async-unix")
+ (version "0.15.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/async_unix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z4fgpn93iw0abd7l9kac28qgzgc5qr2x0s1n2zh49lsdn02n6ys"))))
+ (build-system dune-build-system)
+ (propagated-inputs (list ocaml-async-kernel ocaml-core ocaml-core-kernel
+ ocaml-core-unix ocaml-ppx-jane))
+ (properties `((upstream-name . "async_unix")))
+ (home-page "https://github.com/janestreet/async_unix")
+ (synopsis "Monadic concurrency library")
+ (description
+ "Unix-related dependencies for things like system calls and
+threads. Using these, it hooks the Async_kernel scheduler up to either epoll
+or select, depending on availability, and manages a thread pool that blocking
+system calls run in.")
+ (license license:expat)))
+
(define-public ocaml-timezone
(package
(name "ocaml-timezone")