summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-23 09:05:47 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-06 09:44:54 +0300
commit40a42c4348635f186553938015f7e6a06be1e10c (patch)
treeff7fe5edfd61af66e9333e3016a5a95fa57d480d /gnu
parent70fc8f6d619ce9f16a8cc0bbb10a011bd3a9997a (diff)
gnu: linux-libre: Support zram on all kernels.
* gnu/packages/linux.scm (%default-extra-linux-options): Add config options to add zram support.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0e03a52185..2a2b1614f9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -696,6 +696,10 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("CONFIG_PROC_PID_CPUSET" . #t)
;; Allow disk encryption by default
("CONFIG_DM_CRYPT" . m)
+ ;; Support zram on all kernel configs
+ ("CONFIG_ZSWAP" . #t)
+ ("CONFIG_ZSMALLOC" . #t)
+ ("CONFIG_ZRAM" . m)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)