summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-10 02:00:00 +0200
commit40e78353a4699b8edb6600d82df648914c9110b9 (patch)
tree68e5307bd57a8fae705fed988fe0cd1f7d2897b6 /gnu
parent1ad4d00a9522289b94bb230674ffb585f1dcf417 (diff)
Revert "gnu: beignet: Fix build."
This reverts commit 213516f0baf92b6f50bd0c2e005625c0b3421a6f, which removed ICD support entirely.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/opencl.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 56eecec603..74b250cb9d 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -266,10 +266,7 @@ incorporate inside an OpenCL implementation to give it ICD functionalities.")
(list (string-append "-DCLANG_LIBRARY_DIR="
(assoc-ref %build-inputs "clang@3.7") "/lib")
"-DENABLE_GL_SHARING=ON"
- "-DEXPERIMENTAL_DOUBLE=ON"
- ;; disable OCL ICD, which is probably this project:
- ;; https://github.com/OCL-dev/ocl-icd
- "-DOCLICD_COMPAT=0")
+ "-DEXPERIMENTAL_DOUBLE=ON")
#:phases
(modify-phases %standard-phases