summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:24:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:10 +0200
commit4133c2d38633c828d2e0f138dab5fd3bb1e0674a (patch)
tree0864ca44fe8937d2df2509d673bb713d3825ad3e /gnu
parent463710da2352c6225ca834e98ddd878e2e945066 (diff)
gnu: Add texlive-bezierplot.
* gnu/packages/tex.scm (texlive-bezierplot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 039834d31f..ec6e5d7516 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14911,6 +14911,30 @@ is also possible to use Barracuda with a standalone Lua interpreter to draw
barcodes in different graphic formats like SVG.")
(license license:gpl2)))
+(define-public texlive-bezierplot
+ (package
+ (name "texlive-bezierplot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/bezierplot/"
+ "tex/lualatex/bezierplot/")
+ (base32
+ "125gdb9d160g729v3fbsrsrw5abk34jwa4x43yil0mzjls2aq550")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bezierplot")
+ (synopsis "Approximate smooth function graphs with cubic Bezier splines")
+ (description
+ "This package consists of a Lua program as well as a (Lua)LaTeX
+@file{.sty} file. Given a smooth function, @code{bezierplot} returns a smooth
+Bezier path written in TikZ notation, which also matches MetaPost, that
+approximates the graph of the function. For polynomial functions of degree
+lesser or equal to 3 and their inverses the approximation is exact (up to
+numeric precision). @code{bezierplot} also finds special points such as
+extreme points and inflection points and reduces the number of used points.")
+ (license license:lppl1.3c)))
+
(define-public texlive-qrcode
(package
(name "texlive-qrcode")