summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:49:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:36 +0100
commit41faaff11feb04375161ae20350bacf9bdbaed42 (patch)
tree9e2cc7b171db2870e7bb5ae95bb5929c1dc3fe3c /gnu
parent3168796a3f38a362a9f8378b8953d24117e54c30 (diff)
gnu: Add ghc-doctest-0.12.
* gnu/packages/haskell.scm (ghc-doctest-0.12): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 48f25f00d6..5ed06d5563 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4537,6 +4537,24 @@ It is modeled after doctest for Python, see
@uref{http://docs.python.org/library/doctest.html, the Doctest website}.")
(license license:expat)))
+(define-public ghc-doctest-0.12
+ (package (inherit ghc-doctest)
+ (name "ghc-doctest")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/doctest/doctest-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "13h549cpgcvb7c54c7wif28g5wak84dxc3ais0hlqhzk1q6la91a"))))
+ (inputs
+ `(("ghc-code-page" ,ghc-code-page)
+ ,@(package-inputs ghc-doctest)))))
+
(define-public ghc-lifted-base
(package
(name "ghc-lifted-base")