summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 15:02:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:29 +0200
commit44d4e37d0dabe7d57d822aa85857c3fa9794a06b (patch)
tree007cac9e8c5691d7c058c7af1f02bdb0032a6515 /gnu
parenta272567810af1768266c1e3d84735af19b5b23ec (diff)
gnu: Add texlive-luaxml.
* gnu/packages/tex.scm (texlive-luaxml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6de62dab47..e31916ec1e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16937,6 +16937,25 @@ between numbers and units. The package supports both plain LuaTeX and
LuaLaTeX.")
(license license:lppl1.3+)))
+(define-public texlive-luaxml
+ (package
+ (name "texlive-luaxml")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/luaxml/" "tex/luatex/luaxml/")
+ (base32
+ "0j0d9n87rigawqq3xlxk0zi5ry31zqg3p19jmfablvnb9lan3nrc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luaxml")
+ (synopsis "Lua library for reading and serialising XML files")
+ (description
+ "LuaXML is a pure Lua library for reading and serializing XML files. The
+current release is aimed mainly at support for the @code{odsfile} package.")
+ ;; It uses explicitly the same license as Lua.
+ (license license:x11)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")