summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-30 20:04:57 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-11-30 20:09:12 +0200
commit44e30a7647ebe08c1b7a18666f3d66bd385ce86f (patch)
tree7ab9aa5a5be0c19eb33c9460f4eb2e7d52856976 /gnu
parent1c0059da41b4c0c0525ca75c5631f04495126814 (diff)
gnu: python2-keyring: Use python2-pycrypto.
* gnu/packages/python.scm (python2-keyring)[inputs]: Force building with python2-pycrypto.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d69c722de3..cd19462fa2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -875,7 +875,10 @@ password storage.")
(license x11)))
(define-public python2-keyring
- (package-with-python2 python-keyring))
+ (let ((keyring (package-with-python2 python-keyring)))
+ (package (inherit keyring)
+ (inputs
+ `(("python2-pycrypto" ,python2-pycrypto))))))
(define-public python-six
(package