summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-28 08:31:35 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-30 10:41:14 +0300
commit45a973b3471f9e0435e573f0de4458da4a4a18e3 (patch)
tree5daf22160c188ecf68f81cb7e0a4eab7d8781b4a /gnu
parent43412ab967ee00789fe933f916d804aed9961c57 (diff)
gnu: Add emacs-helm-ag.
* gnu/packages/emacs-xyz.scm (emacs-helm-ag): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8fa5f71b9c..c01eba1264 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6292,6 +6292,31 @@ not tied in the trap of backward compatibility.")
for search-based navigation of buffers.")
(license license:gpl2+)))
+(define-public emacs-helm-ag
+ (let ((commit "2fc02c4ead29bf0db06fd70740cc7c364cb650ac")
+ (revision "1"))
+ (package
+ (name "emacs-helm-ag")
+ (version "0.58")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syohex/emacs-helm-ag.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gnn0byywbld6afcq1vp92cjvy4wlag9d1wgymnqn86c3b1bcf21"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)))
+ (home-page "https://github.com/syohex/emacs-helm-ag")
+ (synopsis "Helm interface to the Silver Searcher")
+ (description
+ "This package provides a frontend for grepping tools like ag and ack,
+as well as features for editing search results.")
+ (license license:gpl3+))))
+
(define-public emacs-helm-projectile
(package
(name "emacs-helm-projectile")