summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-06 08:47:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-06 13:06:45 +0300
commit462b567650e6fbe25a562b5e13dfbaa5ee4c55a9 (patch)
tree0cc9e55774ea5a9c8d3f894b0d79cbbde3238e89 /gnu
parentc6f0b0f603540c2be9694ebcbaa4b65b103847bc (diff)
gnu: orc: Use 'modify-phases'.
* gnu/packages/gstreamer.scm (orc)[arguments]: Use the 'modify-phases' syntax.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 08bd679d37..e5078233a9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -72,18 +72,18 @@
(base32
"0jd69ynvr3k70mlxxgbsk047l1rd63m1wkj3qdcq7644xy0gllkx"))))
(build-system gnu-build-system)
- (arguments `(#:phases
- (alist-cons-before
- 'check 'disable-faulty-test
- (lambda _
- ;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
- ;; tests, which fail on some machines. See:
- ;; https://bugzilla.gnome.org/show_bug.cgi?id=735273
- (substitute* '("testsuite/test-limits.c"
- "testsuite/exec_opcodes_sys.c")
- (("if \\(error\\) return 1;")
- "if (error) return 77;")))
- %standard-phases)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'disable-faulty-test
+ (lambda _
+ ;; XXX Disable the 'test-limits' and 'exec_opcodes_sys'
+ ;; tests, which fail on some machines. See:
+ ;; https://bugzilla.gnome.org/show_bug.cgi?id=735273
+ (substitute* '("testsuite/test-limits.c"
+ "testsuite/exec_opcodes_sys.c")
+ (("if \\(error\\) return 1;")
+ "if (error) return 77;")))))))
(home-page "http://code.entropywave.com/orc/")
(synopsis "Oil runtime compiler")
(description