summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-05-23 10:26:49 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2018-05-25 10:36:43 +0200
commit4806d390cb5ffd867dae663f71ea766d44378a2c (patch)
tree8191d6dba6d02e01ee061deb1cd7f62188c7a7d0 /gnu
parenta037a59f83bbc7fabca9b4d6ccaa1e1657be3009 (diff)
gnu: Add python2-gdrivefs.
* gnu/packages/python.scm (python2-gdrivefs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 27deaebdb8..4cda7192fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13399,3 +13399,44 @@ MacFUSE. The binding is created using the standard @code{ctypes} library.")
(define-public python2-fusepy
(package-with-python2 python-fusepy))
+
+(define-public python2-gdrivefs
+ (package
+ (name "python2-gdrivefs")
+ (version "0.14.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gdrivefs" version))
+ (sha256
+ (base32
+ "0v9sp2cfg4ki3wagkwf3rnfpjhvgf845anz3757il9z95yvvcvb7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-setup-py
+ (lambda _
+ ;; Update requirements from dependency==version
+ ;; to dependency>=version
+ (substitute* "gdrivefs/resources/requirements.txt"
+ (("==") ">="))
+ #t)))))
+ (native-inputs
+ `(("python2-gipc" ,python2-gipc)
+ ("python2-gevent" ,python2-gevent)
+ ("python2-greenlet" ,python2-greenlet)
+ ("python2-httplib2" ,python2-httplib2)
+ ("python2-uritemplate" ,python2-uritemplate)
+ ("python2-oauth2client" ,python2-oauth2client)
+ ("python2-six" ,python2-six)))
+ (propagated-inputs
+ `(("python2-dateutil" ,python2-dateutil)
+ ("python2-fusepy" ,python2-fusepy)
+ ("python2-google-api-client" ,python2-google-api-client)))
+ (home-page "https://github.com/dsoprea/GDriveFS")
+ (synopsis "Mount Google Drive as a local file system")
+ (description "@code{gdrivefs} provides a FUSE wrapper for Google Drive
+under Python 2.7.")
+ (license license:gpl2)))