summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:35:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:15 +0200
commit487f16723091a16bfc3fc886f882547c4cc0eaf2 (patch)
treea971d5a8b2f69554b362c06b26e4ffc813719800 /gnu
parent98dc1825330243948d65e2ee2641c17f509e1056 (diff)
gnu: Add texlive-interpreter.
* gnu/packages/tex.scm (texlive-interpreter): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4c6d9e619b..d6460bb555 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9223,6 +9223,28 @@ superscripts and subscripts more closely resemble @code{\\textstyle} and
@code{\\mathord}, effectively eliminating this class.")
(license license:lppl1.3c)))
+(define-public texlive-interpreter
+ (package
+ (name "texlive-interpreter")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/luatex/interpreter/"
+ "tex/luatex/interpreter/")
+ (base32
+ "03h6bjhvbl3bfkiyssplivqmn2986asv8b1jvr1ahsh7p04bkk4j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/interpreter")
+ (synopsis "Translate input files on the fly")
+ (description
+ "The package preprocesses input files to a Lua(La)TeX run, on the fly.
+The user defines Lua regular expressions to search for patterns and modify
+input lines (or entire paragraphs) accordingly, before TeX reads the material.
+In this way, documents may be prepared in a non-TeX language (e.g., some
+lightweight markup language) and turned into proper TeX for processing.")
+ (license license:lppl)))
+
(define-public texlive-times
(package
(name "texlive-times")