summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-09-22 21:00:24 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-09-22 21:00:24 +0200
commit493b6f6d145a86e528b01701a25a48c7bfa1b3e3 (patch)
treecba53e948c57102892179d6c8f93514305f2471f /gnu
parent2e8b4f9bfa00489fd3acff305837a79af236e183 (diff)
gnu: icedove: Update to 91.13.1 [security fixes].
Fixes CVE-2022-3032, CVE-2022-3033 and CVE-2022-3034. * gnu/packages/gnuzilla.scm (icedove): Update to 91.13.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 5f6d429d25..b3a301709f 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1520,11 +1520,11 @@ standards of the IceCat project.")
icecat-dir)))))))))
;; Update this together with icecat!
-(define %icedove-build-id "20220726000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220919000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "91.12.0")
+ (version "91.13.1")
(source icecat-91-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1803,7 +1803,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "bd3da11e22d0070699026cb5f4e31b44b35580f0"))
+ ,(let ((changeset "2f9b465346ceb38b4ab79ccc1bfe8d8ad0bc8743"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1812,7 +1812,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "14na1n37sqjqcxmhbp0c56a1j70gnyqgrhlrk5jkblml47x4i35w")))))
+ "10vsbwlh5imq7iljwzq3r4y80wzsmj6s2gsi1n64l0wmfq2m6ilb")))))
("cargo" ,rust "cargo")
("clang" ,clang)
("llvm" ,llvm)