summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:46 +0000
commit49bb13b0a759be4adb69aee8fca57d65a780e128 (patch)
tree881dfe22e9d54275858b820f39e553d07780d8e8 /gnu
parent466fe22a89f642a6d2198faa5010b61f0cba8f31 (diff)
gnu: node-ieee754: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-ieee754): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 10e065f1da..699e35b96f 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -301,6 +301,32 @@ projects under a given directory. It uses the gradle wrapper to execute the
clean task of each project.")
(license license:expat)))
+(define-public node-ieee754
+ (package
+ (name "node-ieee754")
+ (version "1.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/feross/ieee754")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19rlg59lavnwsvbblhvrqwinz2wzqlxhddqpwrc3cyqkscjgza7i"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda _
+ (delete-dependencies '("airtap" "standard" "tape")))))))
+ (home-page "https://github.com/feross/ieee754")
+ (synopsis "Read/write IEEE754 floating point numbers in Javascript")
+ (description "This package can read and write IEEE754 floating point
+numbers from/to a Buffer or array-like object in Javascript.")
+ (license license:bsd-3)))
+
(define-public node-long-stack-traces
(package
(name "node-long-stack-traces")
@@ -753,32 +779,6 @@ function with browser support.")
particular cross-platform spellings of the PATH environment variable key.")
(license license:expat)))
-(define-public node-ieee754
- (package
- (name "node-ieee754")
- (version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/feross/ieee754")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19rlg59lavnwsvbblhvrqwinz2wzqlxhddqpwrc3cyqkscjgza7i"))))
- (build-system node-build-system)
- (arguments
- '(#:tests? #f
- #:phases (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda _
- (delete-dependencies '("airtap" "standard" "tape")))))))
- (home-page "https://github.com/feross/ieee754")
- (synopsis "Read/write IEEE754 floating point numbers in Javascript")
- (description "This package can read and write IEEE754 floating point
-numbers from/to a Buffer or array-like object in Javascript.")
- (license license:bsd-3)))
-
(define-public node-inherits
(package
(name "node-inherits")