summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:42:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:36 +0100
commit4a1b5600dcacb84496923803bd0bf48b6a45895d (patch)
tree7a8ba010b017d539a3006f457c4d5ff1def6fdfd /gnu
parent3f229b1b9e2b2aa19bcbf80ad870545e947cc63f (diff)
gnu: ghc-profunctors: Update to 5.2.2.
* gnu/packages/haskell.scm (ghc-profunctors): Update to 5.2.2. [inputs]: Add ghc-base-orphans, ghc-bifunctors, ghc-contravariant, and ghc-semigroups.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3eb8724562..7bba4e5c11 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2709,7 +2709,7 @@ this package makes them available back to GHC 7.2.")
(define-public ghc-profunctors
(package
(name "ghc-profunctors")
- (version "5.1.1")
+ (version "5.2.2")
(source
(origin
(method url-fetch)
@@ -2719,11 +2719,15 @@ this package makes them available back to GHC 7.2.")
".tar.gz"))
(sha256
(base32
- "0lw2ipacpnp9yqmi8zsp01pzpn5hwj8af3y0f3079mddrmw48gw7"))))
+ "0s1pwjidbn761xk43pmzyvn99hm3psdifjd78ylki7f97aiyd0g9"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-distributive" ,ghc-distributive)
+ `(("ghc-base-orphans" ,ghc-base-orphans)
+ ("ghc-bifunctors" ,ghc-bifunctors)
("ghc-comonad" ,ghc-comonad)
+ ("ghc-contravariant" ,ghc-contravariant)
+ ("ghc-distributive" ,ghc-distributive)
+ ("ghc-semigroups" ,ghc-semigroups)
("ghc-tagged" ,ghc-tagged)))
(home-page "https://github.com/ekmett/profunctors/")
(synopsis "Profunctors for Haskell")