summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-29 11:45:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-23 10:34:34 +0100
commit4c8e7ca01dc39cd0704f1a4a1ba060e75784869b (patch)
tree887e9d68b791d6c8b198370b78e9effb601861dc /gnu
parentc9ef13bb19bcb2173cb93687150772217111091d (diff)
gnu: texlive-latex-pdfx: Use simple-texlive-package.
* gnu/packages/tex.scm (texlive-latex-pdfx): Implement with simple-texlive-package. [native-inputs]: Remove. [propagated-inputs]: Replace texlive-generic-pdftex with texlive-pdftex.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm85
1 files changed, 35 insertions, 50 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 99f3700ab2..532c794618 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7140,57 +7140,42 @@ the file to which it applies.")
(license license:gpl3+)))
(define-public texlive-latex-pdfx
- (package
- (name "texlive-latex-pdfx")
- (version (number->string %texlive-revision))
- (source
- (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "pdfx"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "18294h0cr05fs424m3x6aq24z5hf5zmiflalkj4kvpmsyyqqsj74"))))
- (build-system texlive-build-system)
- (arguments
- '(#:tex-directory "latex/pdfx"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-encoding
- (lambda _
- (substitute* "pdfx.dtx"
- ((" .+umaczy") "umaczy"))
- #t))
- (add-before 'install 'install-tex-files
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((target (string-append (assoc-ref outputs "out")
- "/share/texmf-dist/tex/latex/pdfx")))
- (mkdir-p target)
- (copy-recursively (assoc-ref inputs "texlive-tex-pdfx") target)
- ;; Install the generated version in the "install" phase.
- (delete-file (string-append target "/pdfx.sty"))
- #t))))))
- (propagated-inputs
- `(("texlive-generic-pdftex" ,texlive-generic-pdftex)))
- (native-inputs
- `(("texlive-tex-pdfx"
- ,(origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/pdfx"))
- (revision %texlive-revision)))
- (file-name (string-append "texlive-tex-latex-pdfx-" version "-checkout"))
- (sha256
- (base32
- "171ffvpkj2fab4ljcxv3l6l5c8ga8zavdhmhfq07id8zyyr619ip"))))))
- (home-page "https://www.ctan.org/pkg/pdfx")
- (synopsis "PDF/X and PDF/A support for pdfTeX, LuaTeX and XeTeX")
- (description
- "This package helps LaTeX users to create PDF/X, PDF/A and other
+ (let ((template (simple-texlive-package
+ "texlive-latex-pdfx"
+ (list "/doc/latex/pdfx/"
+ "/source/latex/pdfx/"
+ "/tex/latex/pdfx/")
+ (base32
+ "1z4j4d92k2fjmf8jfap4zn7ij97d9rz2jcs9aslcac07ag4x5bdp"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/pdfx")
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'delete-generated-file
+ (lambda _
+ ;; Generate this file from sources
+ (delete-file "tex/latex/pdfx/pdfx.sty")
+ #t))
+ (add-after 'delete-generated-file 'chdir
+ (lambda _ (chdir "source/latex/pdfx") #t))
+ (add-after 'chdir 'fix-encoding
+ (lambda _
+ (substitute* "pdfx.dtx"
+ ((" .+umaczy") "umaczy"))
+ #t))))))
+ (propagated-inputs
+ `(("texlive-pdftex" ,texlive-pdftex)))
+ (home-page "https://www.ctan.org/pkg/pdfx")
+ (synopsis "PDF/X and PDF/A support for pdfTeX, LuaTeX and XeTeX")
+ (description
+ "This package helps LaTeX users to create PDF/X, PDF/A and other
standards-compliant PDF documents with pdfTeX, LuaTeX and XeTeX.")
- (license license:lppl1.2+)))
+ (license license:lppl1.2+))))
+
(define-public texlive-ydoc
(let ((template (simple-texlive-package