summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2024-04-01 23:03:26 +0200
committerLeo Famulari <leo@famulari.name>2024-04-02 15:04:26 -0400
commit4d994f98a49e1a6e58b9b0b512a05efc1c431a50 (patch)
tree45d82a78590d7d9056e4fb15d5006c305c4b2048 /gnu
parente82dc389f58f3f2de1ba65fcd1d7584908ab5a14 (diff)
gnu: gpaste: Update to 44.1.
* gnu/packages/gnome-xyz.scm (gpaste): Update to 44.1. [native-inputs]: Replace GCR-3 with GCR. [inputs]: Replace GTK with GTK+. Add DESKTOP-FILE-UTILS. Remove LIBARCHIVE. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: I9e9548a9e3393dfa4b9e7b64978418106fb25db1
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index d81cf034a1..e8f70f477e 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -1011,7 +1011,7 @@ dark, switch backgrounds and run custom commands at sunset and sunrise.")
(define-public gpaste
(package
(name "gpaste")
- (version "42.2")
+ (version "44.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1020,12 +1020,12 @@ dark, switch backgrounds and run custom commands at sunset and sunrise.")
(file-name (git-file-name name version))
(sha256
(base32
- "0qq2p19p3r3lz8yfynpnf36cipv54bzdbmq1x5zgwhyl4yl41g28"))
+ "1amfr8hwf7401xa3fzaa8w17w3v3lxx0fkr7rqkkyfy57iavrykk"))
(patches
(search-patches "gpaste-fix-paths.patch"))))
(build-system meson-build-system)
(native-inputs
- (list gcr-3
+ (list gcr
gettext-minimal
gobject-introspection
(list glib "bin") ; for glib-compile-resources
@@ -1033,11 +1033,11 @@ dark, switch backgrounds and run custom commands at sunset and sunrise.")
vala))
(inputs
(list appstream-glib
+ desktop-file-utils ; for update-desktop-database
gjs
- gtk
+ gtk+
mutter
- libadwaita
- libarchive))
+ libadwaita))
(arguments
(list #:glib-or-gtk? #true
#:configure-flags