summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:32:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:43 +0200
commit53e0c056fc9e4d0edbe52eb181e8e875ea21f487 (patch)
tree6de8207b7da1e45f98c55f199943055ad3b32793 /gnu
parentc4bb57c1cf8949007a23f5eea219204c425d79eb (diff)
gnu: Add texlive-pst-pulley.
* gnu/packages/tex.scm (texlive-pst-pulley): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d5bb221810..02136a041b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33843,6 +33843,26 @@ polygons are provided, as well as a command @code{\\pspolygonbox} that frames
text with a polygon.")
(license license:lppl)))
+(define-public texlive-pst-pulley
+ (package
+ (name "texlive-pst-pulley")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-pulley/"
+ "tex/generic/pst-pulley/"
+ "tex/latex/pst-pulley/")
+ (base32
+ "1n1kv743vxjw8b6nqrlivb3m3pg3z9kw56bzxij438p5him3sdaa")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-pulley")
+ (synopsis "Plot pulleys, using PSTricks")
+ (description
+ "The package enables the user to draw pulley systems with up to 6 pulleys.
+The pulley diagrams are labelled with the physical properties of the system.")
+ (license license:lppl1.3+)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")