summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2019-05-10 11:19:44 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-14 12:11:04 +0200
commit549d15712fdc1f58ce0dd11117eb79535ec19f2c (patch)
tree22bd09527abb8151cb086499cfd24539271ea15f /gnu
parentae5de93ae2d994dcf555cec0eec6bbd8024321f6 (diff)
gnu: hdf5: Build a thread-safe library.
* gnu/packages/maths.scm (hdf5)[arguments]: Pass "--enable-threadsafe --with-pthread --enable-unsupported".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 59bf101a42..e682746b9e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -781,7 +781,17 @@ incompatible with HDF5.")
`(;; Some of the users, notably Flann, need the C++ interface.
#:configure-flags '("--enable-cxx"
"--enable-fortran"
- "--enable-fortran2003")
+ "--enable-fortran2003"
+
+ ;; Build a thread-safe library. Unfortunately,
+ ;; 'configure' invites you to either turn off C++,
+ ;; Fortran, and the high-level interface (HL), or
+ ;; to pass '--enable-unsupported'. Debian
+ ;; packagers chose to pass '--enable-unsupported'
+ ;; and we follow their lead here.
+ "--enable-threadsafe"
+ "--with-pthread"
+ "--enable-unsupported")
;; Use -fPIC to allow the R bindings to link with the static libraries
#:make-flags (list "CFLAGS=-fPIC"
"CXXFLAGS=-fPIC")
@@ -1093,7 +1103,9 @@ Swath).")
(arguments
(substitute-keyword-arguments (package-arguments hdf5)
((#:configure-flags flags)
- ``("--enable-parallel" ,@(delete "--enable-cxx" ,flags)))
+ ``("--enable-parallel"
+ ,@(delete "--enable-cxx"
+ (delete "--enable-threadsafe" ,flags))))
((#:phases phases)
`(modify-phases ,phases
(add-after 'build 'mpi-setup