summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-02 13:32:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-02 13:42:17 +0100
commit5723503f9f348af008fff7d1f59ff0741fa6f799 (patch)
tree35c6a9dca78e2b64d7805ee824235e07c1f8643c /gnu
parent923a121751041fdc7e0380b2348e7662cc50ed80 (diff)
gnu: python-ipython: Remove trailing #T.
* gnu/packages/python-xyz.scm (python-ipython)[arguments]: Remove trailing #T from build phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f5ff039d24..eb2b8a36ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8697,8 +8697,7 @@ callback signature using a prototype function.")
(substitute* "IPython/sphinxext/ipython_directive.py"
((".*import datetime") "")
((".*datetime.datetime.now\\(\\)") "")
- (("%timeit") "# %timeit"))
- #t))
+ (("%timeit") "# %timeit"))))
;; Tests can only be run after the library has been installed and not
;; within the source directory.
(delete 'check)
@@ -8712,8 +8711,7 @@ callback signature using a prototype function.")
;; We only test the core because one of the other tests
;; tries to import ipykernel.
(invoke "python" "IPython/testing/iptest.py"
- "-v" "IPython/core/tests"))
- #t)))
+ "-v" "IPython/core/tests")))))
(add-before 'check 'fix-tests
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "./IPython/utils/_process_posix.py"
@@ -8725,8 +8723,7 @@ callback signature using a prototype function.")
;; (which depends on ipython).
(delete-file "IPython/core/tests/test_display.py")
;; AttributeError: module 'IPython.core' has no attribute 'formatters'
- (delete-file "IPython/core/tests/test_interactiveshell.py")
- #t)))))
+ (delete-file "IPython/core/tests/test_interactiveshell.py"))))))
(home-page "https://ipython.org")
(synopsis "IPython is a tool for interactive computing in Python")
(description