summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:38:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:48 +0200
commit576fffb7833d5693055785930d54cc62a915aadc (patch)
treede444059a2b1f52035b1b288aab7d60704981fa7 /gnu
parentbc79a0d5fb39b8e2d0ae3685d7ac70334bc19afd (diff)
gnu: Add texlive-pst2pdf.
* gnu/packages/tex.scm (texlive-pst2pdf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7fb5002cf2..84bb9521fa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34388,6 +34388,31 @@ circles.")
relationships such as diphthong membership.")
(license license:lppl)))
+(define-public texlive-pst2pdf
+ (package
+ (name "texlive-pst2pdf")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/pst2pdf/" "scripts/pst2pdf/")
+ (base32
+ "0yihyrnwwpad5hf8yrjqljpwsnj6kcbb6y6cfnxwxbi1c5pf1jk9")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "pst2pdf.pl")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/pst2pdf")
+ (synopsis "Script to compile PSTricks documents via pdfTeX")
+ (description
+ "The script extracts the preamble of the document and runs all
+@code{\\begin@{postscript@}...\\end@{postscript@}},
+@code{\\begin@{pspicture@}...\\end@{pspicture@}} and
+@code{\\pspicture...\\endpspicture} separately through LaTeX with the same
+preamble as the original document; thus it creates EPS, PNG and PDF files of
+these snippets. In a final pdfLaTeX run the script replaces the environments
+with @code{\\includegraphics} to include the processed snippets.")
+ (license license:gpl2)))
+
(define-public texlive-marginnote
(package
(name "texlive-marginnote")