summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-04-27 20:57:58 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-14 12:22:29 +0200
commit58e84ec9afd11b21fae1a87e149902f965326239 (patch)
tree3ce663b78516cb36ba4fc53e98b6b3b8f573779f /gnu
parent3c8d0f9e71bbddfb5b1f098c713ff37553f0efcc (diff)
gnu: Rename json-modern-cxx to nlohmann-json.
* gnu/packages/cpp.scm (nlohmann-json): New variable. (json-modern-cxx): Mark as deprecated alias. (xtl, jsonnet)[inputs]: Use nlohmann-json. * gnu/packages/build-tools.scm (bear)[inputs]: Likewise. * gnu/packages/cybersecurity.scm (blacksmith)[inputs]: Likewise. * gnu/packages/databases.scm (sqlitebrowser)[inputs]: Adjust comment. * gnu/packages/games.scm (openrct2)[inputs]: Use nlohmann-json. * gnu/packages/graphics.scm (f3d)[native-inputs]: Likewise. * gnu/packages/hardware.scm (openrgb)[inputs]: Likewise. [arguments]: Adjust accordingly. * gnu/packages/image-processing.scm (paraview)[inputs]: Adjust comment. * gnu/packages/irods.scm (irods, irods-client-icommands)[inputs]: Use nlohmann-json. * gnu/packages/jupyter.scm (xeus)[inputs]: Likewise. * gnu/packages/messaging.scm (mtxclient, nheko)[inputs]: Likewise. * gnu/packages/text-editors.scm (jucipp)[inputs]: Likewise. * gnu/packages/video.scm (mktoolnix)[inputs]: Likewise. * gnu/packages/xdisorg.scm (nwg-launchers)[inputs]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/build-tools.scm2
-rw-r--r--gnu/packages/cpp.scm13
-rw-r--r--gnu/packages/cybersecurity.scm2
-rw-r--r--gnu/packages/databases.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/graphics.scm2
-rw-r--r--gnu/packages/hardware.scm4
-rw-r--r--gnu/packages/image-processing.scm2
-rw-r--r--gnu/packages/irods.scm4
-rw-r--r--gnu/packages/jupyter.scm2
-rw-r--r--gnu/packages/messaging.scm4
-rw-r--r--gnu/packages/text-editors.scm2
-rw-r--r--gnu/packages/video.scm2
-rw-r--r--gnu/packages/xdisorg.scm2
14 files changed, 24 insertions, 21 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 33d91e6043..95de386ba7 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -148,7 +148,7 @@ makes a few sacrifices to acquire fast full and incremental build times.")
`(("c-ares" ,c-ares)
("fmt" ,fmt-8)
("grpc" ,grpc)
- ("json-modern-cxx" ,json-modern-cxx)
+ ("nlohmann-json" ,nlohmann-json)
("protobuf" ,protobuf)
("python" ,python-wrapper)
("re2" ,re2)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 242ea088bb..02dbcd226a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -596,9 +596,9 @@ converting data between JSON representation and C++ structs. DTO stands for
data transfer object.")
(license license:bsd-3)))
-(define-public json-modern-cxx
+(define-public nlohmann-json
(package
- (name "json-modern-cxx")
+ (name "nlohmann-json")
(version "3.10.5")
(home-page "https://github.com/nlohmann/json")
(source
@@ -662,10 +662,13 @@ data transfer object.")
(inputs
(list doctest fifo-map))
(synopsis "JSON parser and printer library for C++")
- (description "JSON for Modern C++ is a C++ JSON library that provides
+ (description "@code{nlohmann::json} is a C++ JSON library that provides
intuitive syntax and trivial integration.")
(license license:expat)))
+(define-public json-modern-cxx
+ (deprecated-package "json-modern-cxx" nlohmann-json))
+
(define-public xtl
(package
(name "xtl")
@@ -681,7 +684,7 @@ intuitive syntax and trivial integration.")
"134pgvmf9cx5dxs0m0m3qhp3m3r1gl86ic3xax21zc4sdj8sdq46"))
(file-name (git-file-name name version))))
(native-inputs
- (list doctest googletest json-modern-cxx))
+ (list doctest googletest nlohmann-json))
(arguments
'(#:configure-flags
'("-DBUILD_TESTS=ON")
@@ -1860,7 +1863,7 @@ of reading and writing XML.")
(native-inputs
(list googletest pkg-config))
(inputs
- (list json-modern-cxx))
+ (list nlohmann-json))
(home-page "https://jsonnet.org/")
(synopsis "Data templating language")
(description "Jsonnet is a templating language extending JSON
diff --git a/gnu/packages/cybersecurity.scm b/gnu/packages/cybersecurity.scm
index 7bca251d06..cb03cbd5aa 100644
--- a/gnu/packages/cybersecurity.scm
+++ b/gnu/packages/cybersecurity.scm
@@ -89,7 +89,7 @@
(native-inputs
(list pkg-config))
(inputs
- (list argagg asmjit json-modern-cxx))
+ (list argagg asmjit nlohmann-json))
(home-page "https://comsec.ethz.ch/research/dram/blacksmith")
(synopsis "Rowhammer fuzzer with non-uniform and frequency-based patterns")
(description
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 56b971206a..496aab918a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5013,7 +5013,7 @@ a Gtk.Grid Widget.")
(build-system qt-build-system)
(arguments
(list #:configure-flags
- ;; TODO: Unbundle json (json-modern-cxx).
+ ;; TODO: Unbundle json (nlohmann-json).
#~(list (string-append "-DQSCINTILLA_INCLUDE_DIR="
#$(this-package-input "qscintilla")
"/include/Qsci")
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bae79ee48b..d1e2248588 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4893,7 +4893,7 @@ Transport Tycoon Deluxe.")
("freetype" ,freetype)
("icu4c" ,icu4c)
("jansson" ,jansson)
- ("json-modern-cxx" ,json-modern-cxx)
+ ("nlohmann-json" ,nlohmann-json)
("libpng" ,libpng)
("libzip" ,libzip)
("mesa" ,mesa)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 261fcf9547..0951770b12 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -2535,7 +2535,7 @@ a tetrahedral mesh, isovalue discretization and Lagrangian movement;
(native-inputs
(list cxxopts
help2man
- json-modern-cxx))
+ nlohmann-json))
(inputs
(list alembic
assimp
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 5b85ad9b2e..c23299d1db 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -1059,7 +1059,7 @@ technology, such as head mounted displays with built in head tracking.")
(string-append #$(this-package-input "hueplusplus")
"/include/hueplusplus"))
(("dependencies/json")
- (string-append #$(this-package-input "json-modern-cxx")
+ (string-append #$(this-package-input "nlohmann-json")
"/include/nlohmann")))))
;; Call qmake instead of configure to create a Makefile.
(replace 'configure
@@ -1067,7 +1067,7 @@ technology, such as head mounted displays with built in head tracking.")
(inputs
(list hidapi
hueplusplus
- json-modern-cxx
+ nlohmann-json
libusb
mbedtls-apache
qtbase-5))
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index cc0d5789b3..0aaac00870 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1213,7 +1213,7 @@ in 3D or programmatically using ParaView’s batch processing capabilities.")
glew
gmsh
hdf5
- ;;json-modern-cxx ;For ParFlow; build fails
+ ;;nlohmann-json ;For ParFlow; build fails
jsoncpp
libjpeg-turbo
libogg
diff --git a/gnu/packages/irods.scm b/gnu/packages/irods.scm
index 5c9b66000c..a14ac87aa2 100644
--- a/gnu/packages/irods.scm
+++ b/gnu/packages/irods.scm
@@ -143,7 +143,7 @@
("boost" ,boost-for-irods)
("cppzmq" ,cppzmq)
("fmt" ,fmt-6)
- ("json" ,json-modern-cxx)
+ ("json" ,nlohmann-json)
("libarchive" ,libarchive)
("libcxxabi" ,libcxxabi-6) ; we need this for linking with -lc++abi
("linux-pam" ,linux-pam)
@@ -247,7 +247,7 @@ stored.")
("cppzmq" ,cppzmq)
("fmt" ,fmt-6)
("irods" ,irods)
- ("json" ,json-modern-cxx)
+ ("json" ,nlohmann-json)
("libarchive" ,libarchive)
("libcxxabi" ,libcxxabi-6) ; we need this for linking with -lc++abi
("mit-krb5" ,mit-krb5)
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index d0fcc82076..9337197cb2 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -196,7 +196,7 @@ Messaging Protocol}.")
python-jupyter-client))
(inputs
(list xtl
- json-modern-cxx
+ nlohmann-json
cppzmq
zeromq
openssl
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2fa1c45f98..8441e41351 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2325,7 +2325,7 @@ QMatrixClient project.")
(list boost
coeurl
curl
- json-modern-cxx
+ nlohmann-json
libevent
libsodium
olm
@@ -2408,7 +2408,7 @@ for the Matrix protocol. It is built on to of @code{Boost.Asio}.")
gst-plugins-base
gst-plugins-bad ; sdp & webrtc for voip
gst-plugins-good-qt ; rtpmanager for voip
- json-modern-cxx
+ nlohmann-json
libevent
libnice ; for voip
olm
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 8714940d1c..b23c5ba2be 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -393,7 +393,7 @@ bindings and many of the powerful features of GNU Emacs.")
clang-11 ;XXX: must be the same version as Mesas LLVM
gtkmm-3
gtksourceviewmm
- json-modern-cxx
+ nlohmann-json
libgit2
universal-ctags))
(synopsis "Lightweight C++ IDE")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0abc153c60..4769b89a59 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1028,7 +1028,7 @@ H.264 (MPEG-4 AVC) video streams.")
("gettext" ,gettext-minimal)
("googletest" ,googletest)
("libxslt" ,libxslt)
- ("json-modern-cxx" ,json-modern-cxx)
+ ("nlohmann-json" ,nlohmann-json)
("perl" ,perl)
("pkg-config" ,pkg-config)
("po4a" ,po4a)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index bee9711a74..3d66ddc862 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3149,7 +3149,7 @@ such as sway, similar to @command{rofi}.")
(base32
"0hq2qiqxvrw3g515ywcb676ljc8mdw3pyslgxr3vahizfljah1pv"))))
(build-system meson-build-system)
- (native-inputs (list json-modern-cxx pkg-config))
+ (native-inputs (list nlohmann-json pkg-config))
(inputs (list gtk-layer-shell gtkmm-3 librsvg))
(home-page "https://github.com/nwg-piotr/nwg-launchers")
(synopsis "Application launchers for wlroots")