summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-08-16 09:02:29 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-16 09:04:21 +0200
commit591a3f5714231b0820d5814299d90dc92af6e585 (patch)
treeb508ddb6c997724825ece5055e66934edb7d5894 /gnu
parent5bf00ed012ec74ab134c5ed040de6efc84c82f71 (diff)
gnu: bpython: Update to 0.21.
* gnu/packages/python-xyz.scm (bpython): Update to 0.21. [propagated-inputs]: Use python-cwcwidth instead of python-wcwidth. Add python-pyxdg. [native-inputs]: Add python-tox and python-wheel.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9fdd133db5..aaeede354a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -142,6 +142,7 @@
#:use-module (gnu packages enchant)
#:use-module (gnu packages file)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
#:use-module (gnu packages geo)
#:use-module (gnu packages ghostscript)
@@ -20009,13 +20010,13 @@ Included are implementations of:
(define-public bpython
(package
(name "bpython")
- (version "0.20.1")
+ (version "0.21")
(source
(origin
(method url-fetch)
(uri (pypi-uri "bpython" version))
(sha256
- (base32 "00vmkkc79mlnkyvwww1cr7bpwmf4p61704dhayz6kd0kc203hxvf"))))
+ (base32 "11wlf12nm6ggn9512y4yqs26s8gdgpx0h9ls94k7fsjgjy4rpal8"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -20041,14 +20042,17 @@ Included are implementations of:
("python-curtsies" ,python-curtsies)
("python-greenlet" ,python-greenlet)
("python-six" ,python-six)
- ("python-wcwidth" ,python-wcwidth)
+ ("python-cwcwidth" ,python-cwcwidth)
+ ("python-pyxdg" ,python-pyxdg)
;; optional dependencies
("python-urwid" ,python-urwid) ; for bpython-urwid only
("python-watchdog" ,python-watchdog)
("python-jedi" ,python-jedi)))
(native-inputs
`(("python-sphinx" ,python-sphinx)
- ("python-mock" ,python-mock)))
+ ("python-mock" ,python-mock)
+ ("python-tox" ,python-tox)
+ ("python-wheel" ,python-wheel)))
(home-page "https://bpython-interpreter.org/")
(synopsis "Fancy interface to the Python interpreter")
(description "Bpython is a fancy interface to the Python