summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-23 13:54:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 16:40:18 +0200
commit599655dc496491c2569689811d667df6ffeb396c (patch)
tree4c67912bf0ae2bd66890ee8098170c5520f8676e /gnu
parent3f755098cb6d92d5bbe9e4f780ec1d5a5c74e9b5 (diff)
gnu: Add r-attract.
* gnu/packages/bioconductor.scm (r-attract): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e7354aa4e3..ad20602ff6 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2317,6 +2317,37 @@ reproducible gene expression signatures capable of accurately distinguishing
tumor samples from healthy controls.")
(license license:artistic2.0)))
+(define-public r-attract
+ (package
+ (name "r-attract")
+ (version "1.48.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "attract" version))
+ (sha256
+ (base32
+ "0f1fsv278kpnxvqg9qa5rw2k3zr8zws0ab73ldl60h6pv9cy8x82"))))
+ (properties `((upstream-name . "attract")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-annotationdbi
+ r-biobase
+ r-cluster
+ r-gostats
+ r-keggrest
+ r-limma
+ r-org-hs-eg-db
+ r-reactome-db))
+ (home-page "https://bioconductor.org/packages/attract")
+ (synopsis "Finding drivers of Kauffman's attractor landscape")
+ (description
+ "This package contains the functions to find the gene expression modules
+that represent the drivers of Kauffman's attractor landscape. The modules are
+the core attractor pathways that discriminate between different cell types of
+groups of interest. Each pathway has a set of synexpression groups, which show
+transcriptionally-coordinated changes in gene expression.")
+ (license license:lgpl2.0+)))
+
(define-public r-awfisher
(package
(name "r-awfisher")