summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-02-02 17:00:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-03 11:34:42 +0100
commit59b102cab9d66ba0c561ed9ed8df04f9fc340bd2 (patch)
tree5acdceffc4ea9ac49dae53bc06dcf4e206e6aba1 /gnu
parent89d76adf98e37ecef65cc71804df5b5fada8e774 (diff)
gnu: Add python-demuxem.
* gnu/packages/bioinformatics.scm (python-demuxem): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b8676b0ece..1da464f3c5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1092,6 +1092,35 @@ from high-throughput single-cell RNA sequencing (scRNA-seq) data.")
and sequence consensus.")
(license license:expat)))
+(define-public python-demuxem
+ (package
+ (name "python-demuxem")
+ (version "0.1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "demuxEM" version))
+ (sha256
+ (base32
+ "1bhyxqjk44bmyd26m1smapf68wyf7252kk65i27k50dd3kswgnd6"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs
+ (list python-docopt
+ python-importlib-metadata
+ python-numpy
+ python-pandas
+ python-pegasusio
+ python-scikit-learn
+ python-scipy
+ python-seaborn))
+ (native-inputs (list python-cython python-setuptools-scm))
+ (home-page "https://github.com/lilab-bcb/demuxEM")
+ (synopsis "Analyze cell-hashing/nucleus-hashing data")
+ (description
+ "This is a Python module for analyzing cell-hashing/nucleus-hashing data.
+It is the demultiplexing module of Pegasus, which is used by Cumulus in the
+demultiplexing step.")
+ (license license:bsd-3)))
+
(define-public python-hclust2
(package
(name "python-hclust2")