summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 21:58:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:26 +0200
commit5a48e94dff3525debb7be4b6a3deef68ca8b0004 (patch)
treede3421eaa039565ebfbbf6c1cb67f0a27aefea63 /gnu
parentaf59272f993812f518b319c5a48d29fd6e229d24 (diff)
gnu: rust-mach: Move to (gnu packages crates-apple).
* gnu/packages/crates-io.scm (rust-mach-0.3, rust-mach-0.2, rust-mach-o-sys-0.1): Move from here ... * gnu/packages/crates-apple.scm: ... to here. Change-Id: I7d52ea709974637355038e8b43b4d193940529e0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-apple.scm58
-rw-r--r--gnu/packages/crates-io.scm55
2 files changed, 58 insertions, 55 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index 6e9b73bce6..b7a02ad724 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -2,11 +2,14 @@
;;; Copyright © 2019, 2020, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Valentin Ignatev <valentignatev@gmail.com>
;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021, 2022 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2023 Steve George <steve@futurile.net>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -798,6 +801,61 @@ macOS API for file changes notifications")
(description "This package provides bindings to Apple's frameworks.")
(license license:expat)))
+(define-public rust-mach-0.3
+ (package
+ (name "rust-mach")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mach" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1yksa8lwzqh150gr4417rls1wk20asy9vhp8kq5g9n7z58xyh8xq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))
+ (home-page "https://github.com/fitzgen/mach")
+ (synopsis "Rust interface to the Mach 3.0 kernel that underlies OSX")
+ (description
+ "This package provides a Rust interface to the user-space API of the
+Mach 3.0 kernel that underlies OSX.")
+ (license (list license:asl2.0 license:expat license:bsd-2))))
+
+(define-public rust-mach-0.2
+ (package
+ (inherit rust-mach-0.3)
+ (name "rust-mach")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mach" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1qdhs16cl1j3w7kvy6ak7h8lbyqmr6i3i15qfzpnv9gyrn3j9pc6"))))))
+
+(define-public rust-mach-o-sys-0.1
+ (package
+ (name "rust-mach-o-sys")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "mach_o_sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09l8p7nmzq37450x2h6nb7dzg1sk6dk36a5rkcrcy81zm21lb19y"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/fitzgen/mach_o_sys")
+ (synopsis "Bindings to the OSX mach-o system library")
+ (description "This package provides bindings to the OSX mach-o system
+library")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-metal-0.18
(package
(name "rust-metal")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7a17de5f23..1155dc10a1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -38055,61 +38055,6 @@ lexer.")
"This package provides a collection of great and ubiqutitous macros.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-mach-0.3
- (package
- (name "rust-mach")
- (version "0.3.2")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "mach" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1yksa8lwzqh150gr4417rls1wk20asy9vhp8kq5g9n7z58xyh8xq"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-libc" ,rust-libc-0.2)
- ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))
- (home-page "https://github.com/fitzgen/mach")
- (synopsis "Rust interface to the Mach 3.0 kernel that underlies OSX")
- (description
- "This package provides a Rust interface to the user-space API of the
-Mach 3.0 kernel that underlies OSX.")
- (license (list license:asl2.0 license:expat license:bsd-2))))
-
-(define-public rust-mach-0.2
- (package
- (inherit rust-mach-0.3)
- (name "rust-mach")
- (version "0.2.3")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "mach" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "1qdhs16cl1j3w7kvy6ak7h8lbyqmr6i3i15qfzpnv9gyrn3j9pc6"))))))
-
-(define-public rust-mach-o-sys-0.1
- (package
- (name "rust-mach-o-sys")
- (version "0.1.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "mach_o_sys" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "09l8p7nmzq37450x2h6nb7dzg1sk6dk36a5rkcrcy81zm21lb19y"))))
- (build-system cargo-build-system)
- (home-page "https://github.com/fitzgen/mach_o_sys")
- (synopsis "Bindings to the OSX mach-o system library")
- (description "This package provides bindings to the OSX mach-o system
-library")
- (license (list license:asl2.0 license:expat))))
-
(define-public rust-macrotest-1
(package
(name "rust-macrotest")