summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-01 13:21:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-01 14:23:08 +0200
commit5ab679f4dacbc8c6da3a551e284cb41d6a0f6792 (patch)
tree8612aa46134ea201471c7fc1830bbbe130321de9 /gnu
parent42aee121036fb39231b4dd2cb770c489d5a524c1 (diff)
gnu: Add libpst.
* gnu/packages/mail.scm (libpst): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 052adb6160..f75cd910e5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4407,6 +4407,34 @@ score.")
undelete email messages from Outlook Express .dbx files.")
(license license:gpl3+)))
+(define-public libpst
+ (package
+ (name "libpst")
+ (version "0.6.76")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.five-ten-sg.com/libpst/packages/"
+ "libpst-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hhbbb8ddsgjhv9y1xd8s9ixlhdnjmhw12v06jwx4j6vpgp1na9x"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("libgsf" ,libgsf)
+ ("python" ,python)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://www.five-ten-sg.com/libpst/")
+ (synopsis "")
+ (description "The Libpst utilities include @code{readpst} which can
+convert email messages to both mbox and MH mailbox formats, @code{pst2ldif}
+which can convert the contacts to @code{.ldif} format for import into LDAP
+databases, and other tools to process Outlook email archives.")
+ (license license:gpl2+)))
+
(define-public crm114
(package
(name "crm114")