summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:50:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:20 +0200
commit5b84e7f82b1829dc33af9c13aac615587a4f798d (patch)
tree6dfbd0028119e2d5ee7966149f0d6579d8779259 /gnu
parentaffd215764d0b7a9aa2d6ad7908478bbe64c3d3c (diff)
gnu: Add texlive-luacensor.
* gnu/packages/tex.scm (texlive-luacensor): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6dfa589646..25c6c36f6a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16337,6 +16337,30 @@ symbolic computations within LaTeX without the need for laborious and
technical setup.")
(license license:lppl1.3c)))
+(define-public texlive-luacensor
+ (package
+ (name "texlive-luacensor")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luacensor/"
+ "tex/lualatex/luacensor/")
+ (base32
+ "0nw83zzpb9y4vnm4rjz786nz9fxv1vzlz3dv8fjwxqpxngqws4g8")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luacensor")
+ (synopsis "Securely redact sensitive information using Lua")
+ (description
+ "This package provides simple tools for creating redacted contents. Its
+tools are useful for lawyers, workers in sensitive industries, and others who
+need to easily produce both unrestricted versions of documents (for limited,
+secure release) and restricted versions of documents (for general release).
+Redaction is done both by hiding all characters and by slightly varying the
+length of strings to prevent jigsaw identification. It also is friendly to
+screen readers by adding alt-text indicating redacted content.")
+ (license license:lppl1.3+)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")