summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-05-04 14:56:49 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-05-04 19:22:04 +0200
commit5daf470e4fa4d16486d32c767e8d5e257cefebf6 (patch)
tree41a75ada6f2d11fbc71f35a498cbccdea4740e44 /gnu
parent040cf2df74530496fe0e7526aadfb402d9b67f43 (diff)
gnu: Add python-goatools.
* gnu/packages/bioinformatics.scm (python-goatools): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7db8a91e80..7ee97e3da5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12337,6 +12337,48 @@ selection of file types and formats for handling genomic region data---all
using the same syntax.")
(license license:expat)))
+(define-public python-goatools
+ (package
+ (name "python-goatools")
+ (version "1.3.1")
+ ;; Pypi tarball doesn't include test files.
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tanghaibao/goatools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0a295zk9jc8kny5vnka63q3gbksins42kcmgvskf8xy7hkca7cmq"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Almost all tests require access to the internet.
+ #:tests? #false
+ #:test-flags
+ ;; These have syntax errors.
+ '(list "--ignore=tests/test_i195_sgd_gaf.py"
+ "--ignore=tests/test_i206.py"
+ "--ignore=tests/test_setup_dirs.py")))
+ (propagated-inputs (list python-docopt
+ python-numpy
+ python-openpyxl
+ python-pandas
+ python-pydot
+ python-requests
+ python-scipy
+ python-statsmodels
+ python-xlsxwriter))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/tanghaibao/goatools")
+ (synopsis "Python scripts to find enrichment of GO terms")
+ (description "Python scripts to find enrichment of GO terms. In addition,
+this package is used for processing the obo-formatted file from Gene Ontology
+website. The data structure is a directed acyclic graph that allows easy
+traversal from leaf to root.")
+ (license license:bsd-2)))
+
(define-public python-loompy
(package
(name "python-loompy")