summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-10 18:12:31 +0100
committerLudovic Courtès <ludo@gnu.org>2023-12-10 21:46:51 +0100
commit5f0811a9aa652f51642ea69eb59dd4276624cb5b (patch)
tree9cf4bf926076ce5b2d9be114fd2982b37f758b6f /gnu
parente15419673618566eb5d7e568be184af7aa3ec742 (diff)
gnu: Add KeePassXC-Browser.
* gnu/packages/browser-extensions.scm (keepassxc-browser) (keepassxc-browser-icecat): New variable. Change-Id: I6f85228e4e012f3e5f8c913fda38287255573604
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/browser-extensions.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/browser-extensions.scm b/gnu/packages/browser-extensions.scm
index 21c519eda3..0b42acc422 100644
--- a/gnu/packages/browser-extensions.scm
+++ b/gnu/packages/browser-extensions.scm
@@ -221,3 +221,33 @@ fill and submit login forms if a matching password entry is found.")
(define-public passff/icecat
(make-icecat-extension passff))
+
+(define keepassxc-browser
+ (package
+ (name "keepassxc-browser")
+ (version "1.8.10")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/keepassxreboot/keepassxc-browser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1059kcb95ig18izbchwlb7pz41l4l3vjwzlmhz3w8zw2qxm6hrvx"))))
+ (build-system copy-build-system)
+ (properties
+ '((addon-id . "keepassxc-browser@keepassxc.org")))
+ (arguments
+ `(#:install-plan
+ '(("keepassxc-browser" ,(assq-ref properties 'addon-id)))))
+ (synopsis "Browser extension for the KeePassXC password manager")
+ (description
+ "This package provides an extension allow the browser to work together
+with the @uref{https://keepassxc.org, KeePassXC} password manager.")
+ (home-page "https://keepassxc.org")
+ (license license:gpl3+)))
+
+(define-public keepassxc-browser/icecat
+ (make-icecat-extension keepassxc-browser))