summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:41:50 +0100
committerDavid Craven <david@craven.ch>2017-01-04 17:41:11 +0100
commit63147e5e1e088a266779f2572f5177ba085e3157 (patch)
treea244b8736e7071a1aa736a26068b49e0e1ffb446 /gnu
parenta359c7277c9243c6bea6963fc44b547f446fa7dd (diff)
gnu: Add ocaml-rresult.
* gnu/packages/ocaml.scm (ocaml-rresult): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d8c6fcf265..7c57c5abef 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1123,3 +1123,33 @@ provides an API to describe the files a package installs in a given build
configuration and to specify information about the package's distribution,
creation and publication procedures.")
(license license:isc)))
+
+(define-public ocaml-rresult
+ (package
+ (name "ocaml-rresult")
+ (version "0.5.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/rresult/releases/"
+ "rresult-" version ".tbz"))
+ (sha256
+ (base32
+ "1xxycxhdhaq8p9vhwi93s2mlxjwgm44fcxybx5vghzgbankz9yhm"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("opam" ,opam)))
+ (propagated-inputs
+ `(("topkg" ,ocaml-topkg)))
+ (arguments
+ `(#:tests? #f
+ #:build-flags '("build")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://erratique.ch/software/rresult")
+ (synopsis "Result value combinators for OCaml")
+ (description "Handle computation results and errors in an explicit and
+declarative manner, without resorting to exceptions. It defines combinators
+to operate on the result type available from OCaml 4.03 in the standard
+library.")
+ (license license:isc)))