summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-19 00:04:53 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 12:30:50 +0100
commit6385070190348acd61ae3fac4aaccdbcc61797ed (patch)
treea8f1d3300805612d5ee5dac3c93bab53a897c6e9 /gnu
parent39f02b576095a51f3da49c2f6d78185d018b3457 (diff)
gnu: Add julia-astrotime.
* gnu/packages/julia-xyz.scm (julia-astrotime): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 437dd4da3d..a77d700129 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -262,6 +262,36 @@ appropriate BLAS or optimised Julia linear algebra routines. This supports a
much wider class of matrix types than Julia's in-built @code{StridedArray}.")
(license license:expat)))
+(define-public julia-astrotime
+ (package
+ (name "julia-astrotime")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaAstro/AstroTime.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "032hlanan49ypqh4lwlf91pg7052c8h5sgbxqc1771b8j9srbyd2"))))
+ (build-system julia-build-system)
+ (native-inputs
+ (list julia-measurements))
+ (propagated-inputs
+ (list julia-erfa
+ julia-earthorientation
+ julia-itemgraphs
+ julia-macrotools
+ julia-muladdmacro
+ julia-reexport))
+ (home-page "https://github.com/JuliaAstro/AstroTime.jl")
+ (synopsis "Astronomical time keeping in Julia")
+ (description "@code{AstroTime.jl} provides a high-precision, time-scale
+aware, @code{DateTime}-like data type which supports all commonly used
+astronomical time scales.")
+ (license license:expat)))
+
(define-public julia-automa
(package
(name "julia-automa")