summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:12 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:20:26 -0500
commit683c8c9db442c77f4636528b6bf421ae98b4251e (patch)
treea75e3ba8ebc2b871287b9cdf6f43efb6e33a52b5 /gnu
parent9a49beb272e83997480e4a0d61799ca84847274d (diff)
gnu: Add go-github-com-gatherstars-com-jwz.
* gnu/packages/golang.scm (go-github-com-gatherstars-com-jwz): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 71522270a9..52197ee31b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10699,6 +10699,33 @@ text-only mail clients to display them.")
library geared towards parsing MIME encoded emails.")
(license license:expat)))
+(define-public go-github-com-gatherstars-com-jwz
+ (package
+ (name "go-github-com-gatherstars-com-jwz")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gatherstars-com/jwz")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h37h5w139d3rhvp1n7kz2jm5zhk4pjzf3sip04v48nphkika60c"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/gatherstars-com/jwz"))
+ (propagated-inputs (list go-github-com-rivo-tview
+ go-github-com-jhillyerd-enmime
+ go-github-com-gdamore-tcell-v2))
+ (home-page "https://github.com/gatherstars-com/jwz")
+ (synopsis "Implementation in Go of the email threading algorithm
+originally invented for Netscape Mail")
+ (description
+ "The jwz package provides an implementation of the email threading
+algorithm originally designed for use in Netscape Mail 2.0 for Go.")
+ (license license:asl2.0)))
+
(define-public go-github-com-creack-pty
(package
(name "go-github-com-creack-pty")