summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-23 23:20:54 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-24 14:25:49 +0300
commit69c11e51cafe04b370362e8849b57d6da8bafc0c (patch)
treebe541db34655928d8ed9a1adf8b121693b290e9a /gnu
parent6b017ed5dde6dc5ed04f52128afbcf89056c959d (diff)
gnu: Add rust-alsa-sys-0.3.
* gnu/packages/crates-io.scm (rust-alsa-sys-0.3): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I3d05e94c15e841b1e848f6fec06b1fa9640da2e5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ba67fd62d7..2ed7f0cd10 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3092,6 +3092,30 @@ be used with the stdlib.")
(description "Mirror of Rust's allocator API.")
(license (list license:expat license:asl2.0))))
+(define-public rust-alsa-sys-0.3
+ (package
+ (name "rust-alsa-sys")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "alsa-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "09qmmnpmlcj23zcgx2xsi4phcgm5i02g9xaf801y7i067mkfx3yv"))))
+ (build-system cargo-build-system)
+ (arguments
+ (list #:tests? #f ; doc tests fail
+ #:cargo-inputs `(("rust-libc" ,rust-libc-0.2)
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (native-inputs (list pkg-config alsa-lib))
+ (home-page "https://github.com/diwic/alsa-sys")
+ (synopsis "FFI bindings for the ALSA sound API")
+ (description
+ "FFI bindings for the ALSA sound API. This package contains
+the code to interact with the underlying operating system ALSA interface.")
+ (license license:expat)))
+
(define-public rust-alto-3
(package
(name "rust-alto")