summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:45:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:18 +0200
commit6bc9993d038a87549e9a8f8702260a4f2841aed9 (patch)
tree496c1993f4375f3fe6014f5bb9bef9686fae3a72 /gnu
parent0719c4c4b5e29b2db9f8469209e1240b30d37b50 (diff)
gnu: Add texlive-lua-uca.
* gnu/packages/tex.scm (texlive-lua-uca): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8570cfab3e..74d84240ea 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16185,6 +16185,28 @@ Customisable colours are used to highlight these flaws, and the list of pages
on which typographical flaws were found is printed.")
(license license:lppl1.3c)))
+(define-public texlive-lua-uca
+ (package
+ (name "texlive-lua-uca")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/lua-uca/" "scripts/lua-uca/"
+ "source/support/lua-uca/")
+ (base32
+ "03wpdaz0z3zqfjs43ar65lx521qyf0c2q62b5p53kdx17xfr09jz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lua-uca")
+ (synopsis "Unicode Collation Algorithm library for Lua")
+ (description
+ "The Lua-UCA library provides basic support for Unicode Collation
+Algorithm in Lua. It can be used to sort arrays of strings according to rules
+of particular languages. It can be used in other Lua projects that need to
+sort text in a language dependent way, like indexing processors, bibliographic
+generators, etc.")
+ (license license:expat)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")