summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:36:41 +0100
committerDavid Craven <david@craven.ch>2017-01-04 17:41:11 +0100
commit704b990c36b29bca681b1832e30c0901512b4f9a (patch)
treeb3cb56d4f16e1080b397cb95d0937ebc467e132e /gnu
parent44c23cb8d800ed3480755347b2dfee6a3544d727 (diff)
gnu: Add ocaml-result.
* gnu/packages/ocaml.scm (ocaml-result): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b999ee91e6..9eff014993 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1069,3 +1069,27 @@ and generate binary formats, files and protocols. Bitstring handling is added
as primitives to the language, making it exceptionally simple to use and very
powerful.")
(license license:isc)))
+
+(define-public ocaml-result
+ (package
+ (name "ocaml-result")
+ (version "1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/janestreet/result"
+ "/archive/" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pgpfsgvhxnh0i37fkvp9j8nadns9hz9iqgabj4dr519j2gr1xvw"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://github.com/janestreet/result")
+ (synopsis "Compatibility Result module")
+ (description "Uses the new result type defined in OCaml >= 4.03 while
+staying compatible with older version of OCaml should use the Result module
+defined in this library.")
+ (license license:bsd-3)))