summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-10-04 17:16:19 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-10-04 17:16:19 +0200
commit726d077bde01cede4295aa933be2a5860717cebd (patch)
treec636539319b7502e78bcf3f3f8016fd9e397c7e8 /gnu
parentaa916f343cb8381172713b74362fede304664396 (diff)
gnu: vinagre: Fix compiling with gcc 10.
* gnu/packages/gnome.scm (vinagre)[arguments]: Add '-fcommon' to CFLAGS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c705d68943..69fda3bc8d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4503,7 +4503,8 @@ selection and URL hints.")))
(arguments
;; Disable -Werror and such, to avoid build failures on compilation
;; warnings.
- '(#:configure-flags '("--enable-compile-warnings=minimum")
+ '(#:configure-flags '("--enable-compile-warnings=minimum"
+ "CFLAGS=-fcommon")
#:phases
(modify-phases %standard-phases
(add-before 'install 'skip-gtk-update-icon-cache