summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-04-26 02:15:55 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-09 19:13:22 +0200
commit72aa295e44d46f80a037bfdc68f831bee56efbab (patch)
treef86f577ca772b5ff9811692a9cc411864e2f30e4 /gnu
parent126c9e3ff798d06a8398337bb8c3bb09b3da3d35 (diff)
gnu: Add f2fs-tools@1.7.0.
* gnu/packages/linux.scm (f2fs-tools-1.7): New variable. (f2fs-tools): Inherit from f2fs-tools-1.7.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 30 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ac28b2b453..7648b55764 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3264,10 +3264,10 @@ repair and easy administration.")
from the btrfs-progs package. It is meant to be used in initrds.")
(license (package-license btrfs-progs))))
-(define-public f2fs-tools
+(define-public f2fs-tools-1.7
(package
(name "f2fs-tools")
- (version "1.8.0")
+ (version "1.7.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3275,21 +3275,30 @@ from the btrfs-progs package. It is meant to be used in initrds.")
"/f2fs-tools.git/snapshot/" name "-" version ".tar.gz"))
(sha256
(base32
- "1bir9ladb58ijlcvrjrq1fb1xv5ys50zdjaq0yzliib0apsyrnyl"))))
+ "1m6bn1ibq0p53m0n97il91xqgjgn2pzlz74lb5bfzassx7159m1k"))))
+
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'bootstrap
(lambda _
- (zero? (system* "autoreconf" "-vif")))))))
+ (zero? (system* "autoreconf" "-vif"))))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (out-include (string-append out "/include")))
+ (install-file "include/f2fs_fs.h" out-include)
+ (install-file "mkfs/f2fs_format_utils.h" out-include)
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(inputs
- `(("libuuid" ,util-linux)))
+ `(("libuuid" ,util-linux)
+ ("libselinux" ,libselinux)))
(home-page "https://f2fs.wiki.kernel.org/")
(synopsis "Userland tools for f2fs")
(description
@@ -3300,6 +3309,22 @@ disks and SD cards. This package provides the userland utilities.")
;; GPL2/LGPL2.1, everything else is GPL2 only. See 'COPYING'.
(license (list license:gpl2 license:lgpl2.1))))
+(define-public f2fs-tools
+ (package
+ (inherit f2fs-tools-1.7)
+ (name "f2fs-tools")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://git.kernel.org/cgit/linux/kernel/git/jaegeuk"
+ "/f2fs-tools.git/snapshot/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bir9ladb58ijlcvrjrq1fb1xv5ys50zdjaq0yzliib0apsyrnyl"))))
+ (inputs
+ `(("libuuid" ,util-linux)))))
+
(define-public freefall
(package
(name "freefall")