summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-08 19:54:50 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-06 21:56:07 +0300
commit751c70404b176082e20f6bcc4d014227ccfe2f7d (patch)
tree849e388d30deae8502376e2d619bd65e18e84b3e /gnu
parent3ed3c105e3aef11f21d2e50a529389c0e5aa5555 (diff)
gnu: Add tintin++.
* gnu/packages/games.scm (tintin++): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 88330c7293..d386e2c99f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -101,6 +101,8 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages tcl)
#:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages tls)
+ #:use-module (gnu packages pcre)
#:use-module (guix build-system gnu)
#:use-module (guix build-system haskell)
#:use-module (guix build-system python)
@@ -2736,6 +2738,42 @@ the GNU GPL.")
(home-page "https://supertuxproject.org/")
(license license:gpl3+)))
+(define-public tintin++
+ (package
+ (name "tintin++")
+ (version "2.01.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/tintin"
+ "/files/TinTin++ Source Code/" version
+ "/tintin" "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "195wrfcys8yy953gdrl1gxryhjnx9lg1vqgxm3dyzm8bi18aa2yc"))))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("pcre" ,pcre)
+ ("readline" ,readline)
+ ("zlib" ,zlib)))
+ (arguments
+ '(#:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ ;; The source is in tt/src.
+ (add-before 'configure 'chdir
+ (lambda _
+ (chdir "src")
+ #t)))))
+ (build-system gnu-build-system)
+ (home-page "http://tintin.sourceforge.net/")
+ (synopsis "MUD client")
+ (description
+ "TinTin++ is a MUD client which supports MCCP (Mud Client Compression Protocol),
+MMCP (Mud Master Chat Protocol), xterm 256 colors, most TELNET options used by MUDs,
+as well as those required to login via telnet on Linux / Mac OS X servers, and an
+auto mapper with a VT100 map display.")
+ (license license:gpl2+)))
+
(define-public laby
(package
(name "laby")