summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 10:11:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 10:11:34 +0200
commit7694acebd18d9b32fd01b70819c1e79de05b4f52 (patch)
treeb198d6d5b13a3124318c2f08ed855925d66ffab5 /gnu
parentb602ec9fbad8e9ef30a41ed7d6432b0e4aff7516 (diff)
gnu: r-summarizedexperiment: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-summarizedexperiment): Move variable from here... * gnu/packages/bioconductor.scm (r-summarizedexperiment): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm34
-rw-r--r--gnu/packages/bioinformatics.scm34
2 files changed, 34 insertions, 34 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 79aaf92124..9b49c6ec43 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2395,6 +2395,40 @@ purposes. The package also contains legacy support for early single-end,
ungapped alignment formats.")
(license license:artistic2.0)))
+(define-public r-summarizedexperiment
+ (package
+ (name "r-summarizedexperiment")
+ (version "1.20.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "SummarizedExperiment" version))
+ (sha256
+ (base32
+ "04x6d4mcsnvz6glkmf6k2cv3fs8zk03i9rvv0ahpl793n8l411ps"))))
+ (properties
+ `((upstream-name . "SummarizedExperiment")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-delayedarray" ,r-delayedarray)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-matrix" ,r-matrix)
+ ("r-matrixgenerics" ,r-matrixgenerics)
+ ("r-s4vectors" ,r-s4vectors)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/SummarizedExperiment")
+ (synopsis "Container for representing genomic ranges by sample")
+ (description
+ "The SummarizedExperiment container contains one or more assays, each
+represented by a matrix-like object of numeric or other mode. The rows
+typically represent genomic ranges of interest and the columns represent
+samples.")
+ (license license:artistic2.0)))
+
(define-public r-systempiper
(package
(name "r-systempiper")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index eda7416fb2..de76e67f57 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7838,40 +7838,6 @@ including VCF header and contents in RDF and JSON.")
(home-page "https://github.com/vcflib/bio-vcf")
(license license:expat)))
-(define-public r-summarizedexperiment
- (package
- (name "r-summarizedexperiment")
- (version "1.20.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "SummarizedExperiment" version))
- (sha256
- (base32
- "04x6d4mcsnvz6glkmf6k2cv3fs8zk03i9rvv0ahpl793n8l411ps"))))
- (properties
- `((upstream-name . "SummarizedExperiment")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-delayedarray" ,r-delayedarray)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-genomicranges" ,r-genomicranges)
- ("r-iranges" ,r-iranges)
- ("r-matrix" ,r-matrix)
- ("r-matrixgenerics" ,r-matrixgenerics)
- ("r-s4vectors" ,r-s4vectors)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/SummarizedExperiment")
- (synopsis "Container for representing genomic ranges by sample")
- (description
- "The SummarizedExperiment container contains one or more assays, each
-represented by a matrix-like object of numeric or other mode. The rows
-typically represent genomic ranges of interest and the columns represent
-samples.")
- (license license:artistic2.0)))
-
(define-public r-genomicalignments
(package
(name "r-genomicalignments")