summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWamm K. D <jaft.r@outlook.com>2023-12-16 20:24:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-20 21:35:29 +0000
commit782d69fb7f88eeb5ea470f365d8ecbc761dfa1ff (patch)
treeb54e365d5e887b4f93e7add38b6741831be79965 /gnu
parent9072f27f5d3514be22c6af208f2ad56ef4e112f4 (diff)
gnu: Add python-manimpango.
* gnu/packages/python-xyz.scm (python-manimpango): New variable. Co-authored-by: Troy Figiel <troy@troyfigiel.com> Change-Id: I80effb2412e7c35ddf69c0d3ff6e2f052f282840 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4d692a37de..b23108fbf4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -119,7 +119,7 @@
;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2022 drozdov <drozdov@portalenergy.tech>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
-;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022, 2023 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
@@ -10193,6 +10193,43 @@ service. It allows you to invoke commands on target Windows machines from
any machine that can run Python.")
(license license:expat)))
+(define-public python-manimpango
+ (package
+ (name "python-manimpango")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch) ; no tests data in PyPi package
+ (uri (git-reference
+ (url "https://github.com/ManimCommunity/ManimPango")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00mrvswk8yly0m13jq0f432pr19sy3j6w37lrv78ah1j6jz9n50h"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
+ (native-inputs
+ (list pkg-config
+ python-cython
+ python-pytest
+ python-pytest-cov))
+ (inputs
+ (list pango))
+ (home-page "https://manimpango.manim.community/")
+ (synopsis "Bindings for Pango for using with Manim")
+ (description
+ "Python bindings for ManimPango which is a C binding for Pango,
+using Cython.
+
+ManimPango is internally used in Manim to render (non-LaTeX) text.")
+ (license license:expat)))
+
(define-public python-xcffib
(package
(name "python-xcffib")