summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-08 22:13:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 19:01:21 +0100
commit79ecb5f35f1ec7d5885fd159a13a206fce23c225 (patch)
treee1d9265d14d38e4c060845d2358c0c1638caf1df /gnu
parent75a9ee5b8e59ac02b6ab8051bd30fbb7454e509c (diff)
gnu: Add r-attempt.
* gnu/packages/cran.scm (r-attempt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6623636e2c..2588bd9238 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -7425,6 +7425,31 @@ information} (NMI), @dfn{adjusted mutual information} (AMI), @dfn{normalized
variation information} (NVI) and entropy.")
(license license:gpl3+)))
+(define-public r-attempt
+ (package
+ (name "r-attempt")
+ (version "0.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "attempt" version))
+ (sha256
+ (base32
+ "1ylgg7jcp8wqmxgf1mydnvh26k0mr8jyjla4hw06730r40yrs58m"))))
+ (properties `((upstream-name . "attempt")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rlang))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/ColinFay/attempt")
+ (synopsis "Tools for defensive programming")
+ (description
+ "This package provides tools for defensive programming. It is inspired
+by @code{purrr} mappers and based on @code{rlang}. Attempt extends and
+facilitates defensive programming by providing a consistent grammar, and a set
+of functions for common tests and conditions. Attempt only depends on
+@code{rlang}, and focuses on speed, so it can be integrated with other
+functions and used in the data analysis.")
+ (license license:expat)))
+
(define-public r-debugme
(package
(name "r-debugme")