summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-09-14 07:48:32 +0100
committerChristopher Baines <mail@cbaines.net>2022-10-06 15:08:03 +0100
commit7a271e688612ae77e69834cc8d4aa82bd2cfdbd9 (patch)
treeba030db5d2a3b4a5c8bdcd33121ee74baf39e530 /gnu
parent44f8aa26bc6a5881fa1106077ecc136713a198a9 (diff)
gnu: Add cpass.
* gnu/packages/password-utils.scm (cpass): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm38
1 files changed, 36 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 003e346305..09752a43d0 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2021 David Dashyan <mail@davie.li>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 ( <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -58,6 +59,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
+ #:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix gexp)
@@ -109,8 +111,7 @@
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages xml)
- #:use-module (guix build-system python))
+ #:use-module (gnu packages xml))
(define-public pwgen
(package
@@ -863,6 +864,39 @@ also install the browser extension for GNU IceCat or ungoogled-chromium
separately.")
(license license:isc)))
+(define-public cpass
+ (package
+ (name "cpass")
+ (version "0.9.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "cpass" version))
+ (sha256
+ (base32
+ "1zp3a8mgqxn916fzj1v2yhgnl7v6s0vnd0qcghqs3qq648qmlwr5"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-pass-refs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "cpass.py"
+ (("'pass'")
+ (string-append "'"
+ (search-input-file inputs
+ "bin/pass")
+ "'"))
+ (("\\.password_store")
+ ".password-store")))))))
+ (inputs (list password-store))
+ (propagated-inputs (list python-urwid))
+ (home-page "https://github.com/OliverLew/cpass")
+ (synopsis "Textual interface for @command{pass}")
+ (description
+ "@command{cpass} is a terminal user interface for @command{pass}.
+It supports both vim-like keybindings and the mouse.")
+ (license license:expat)))
+
(define-public argon2
(package
(name "argon2")