summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:53:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:21 +0200
commit7ab5567de0a960e32e50e3bae7fc05bc05c0b0a7 (patch)
treee3965f0876589d03e2014566589be7eaf56f4ef1 /gnu
parent51e2ec6f7f68812e6e223de717854cf132a6ede6 (diff)
gnu: Add texlive-luaimageembed.
* gnu/packages/tex.scm (texlive-luaimageembed): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f84ef1fb2c..e4b2e38a9e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16449,6 +16449,27 @@ languages and load their patterns by means of @file{language.dat} without
loading @code{babel}.")
(license license:lppl1.3+)))
+(define-public texlive-luaimageembed
+ (package
+ (name "texlive-luaimageembed")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luaimageembed/"
+ "tex/lualatex/luaimageembed/")
+ (base32
+ "0nn4vw7hjyjr8an04dd8xmaskf9qn3zjv29dj37pias3pjq7nqi5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luaimageembed")
+ (synopsis "Embed images as base64-encoded strings")
+ (description
+ "This package allows to embed images directly as base64-encoded strings
+into a LuaLaTeX document. This can be useful, e.g., to package a document
+with images into a single TeX file, or with automatically generated
+graphics.")
+ (license license:expat)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")