summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-09-21 15:38:35 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-24 17:59:05 +0200
commit7ab5c85f4c06ef35c85f38672f5dcbecc65c8906 (patch)
treec4a8d6095c9ec7b509e1b21aa0f6796f2d036736 /gnu
parent736bda211bca805e883c16adb377a2f25874f325 (diff)
gnu: emacs-lua-mode: Fix build.
* gnu/packages/emacs-xyz.scm (emacs-buttercup-1.25): New variable. (emacs-lua-mode): Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5209d35ed0..0e3e0be3b8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -95,7 +95,7 @@
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021, 2022 Stefan Reichör <stefan@xsteve.at>
-;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
@@ -12865,7 +12865,7 @@ using package inferred style.")
`(#:tests? #t
#:test-command '("buttercup" "-l" "lua-mode.el")))
(native-inputs
- (list emacs-buttercup lua))
+ (list emacs-buttercup-1.25 lua))
(synopsis "Major mode for lua")
(description
"This Emacs package provides a mode for @uref{https://www.lua.org/,
@@ -24744,6 +24744,23 @@ common set-up and tear-down code, and allows the programmer to \"spy\" on
functions to ensure they are called with the right arguments during testing.")
(license license:gpl3+)))
+;;; Required by emacs-lua-mode
+(define emacs-buttercup-1.25
+ (package
+ (inherit emacs-buttercup)
+ (name "emacs-buttercup")
+ (version "1.25")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jorgenschaefer/emacs-buttercup")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fsysvsypda6b7azc15bpaprq3bwx4gb6rlq2mj6f8rgwdqc8153"))))))
+
(define-public emacs-cort
(package
(name "emacs-cort")