summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:46 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:19 -0400
commit7f990f736c19e5c3daeb8abd14812bed41247616 (patch)
tree4718d412c5005201e601de794f92091a6f05ad86 /gnu
parent6265c972beaf04cbcfee141721d4c1b03b2f78c6 (diff)
gnu: Add go-github-com-xeipuuv-gojsonreference.
* gnu/packages/golang.scm (go-github-com-xeipuuv-gojsonreference): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a474782beb..7d50dc83f5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12919,6 +12919,32 @@ when comparing complex types like structures and maps.")
programming language.")
(license license:asl2.0))))
+(define-public go-github-com-xeipuuv-gojsonreference
+ (let ((commit "bd5ef7bd5415a7ac448318e64f11a24cd21e594b")
+ (revision "0"))
+ (package
+ (name "go-github-com-xeipuuv-gojsonreference")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xeipuuv/gojsonreference")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xby79padc7bmyb8rfbad8wfnfdzpnh51b1n8c0kibch0kwc1db5"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/xeipuuv/gojsonreference"))
+ (propagated-inputs (list go-github-com-xeipuuv-gojsonpointer))
+ (home-page "https://github.com/xeipuuv/gojsonreference")
+ (synopsis "Implementation of JSON Reference for Go")
+ (description
+ "This package provides an implementation of JSON Reference for the Go
+programming language.")
+ (license license:asl2.0))))
+
(define-public go-github-com-niemeyer-pretty
(package
(name "go-github-com-niemeyer-pretty")