summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:24:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:32 +0200
commit80bfe3a740cb90c61c054a5bf87ff8c0f0657253 (patch)
tree1c1567ab03c38f4160b17221e33032f6dad147e2 /gnu
parentf84fe09bb4fcab02bfbcaf4f5b4e50628e903581 (diff)
gnu: Add texlive-soup.
* gnu/packages/tex.scm (texlive-soup): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 96e3faecf3..37dd86449b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13365,6 +13365,28 @@ scripture references);
@end itemize")
(license license:gpl2)))
+(define-public texlive-soup
+ (package
+ (name "texlive-soup")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/soup/" "source/latex/soup/"
+ "tex/latex/soup/")
+ (base32
+ "04lpc3nn45i66cwnjn0sycdpfaynzkb19djyfi8ca3ppb1sn79z6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/soup")
+ (synopsis "Generate alphabet soup puzzles")
+ (description
+ "This package generates alphabet soup puzzles (aka word search puzzles),
+and variations using numbers or other symbols. It provides macros to generate
+an alphabet soup style puzzle (also known as word search puzzles or
+find-the-word puzzles). It also allows creating number soup and soups with
+custom symbol sets.")
+ (license license:lppl1.3+)))
+
(define-public texlive-spalign
(package
(name "texlive-spalign")