summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-22 21:01:54 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-10 19:26:51 +0100
commit81808194ac78cd77fcb42e9b8e20117ff80834ec (patch)
tree459ff15062156f7978203e78acc981f0691c8fb4 /gnu
parent2cc752c0b0ab801509574d601c1024b73aed0dab (diff)
gnu: Add emacs-rspec.
* gnu/packages/emacs.scm (emacs-rspec): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index abb99f8fc4..b4c3664c4b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2018,6 +2018,31 @@ tables.")
mode-line.")
(license license:gpl2+)))
+(define-public emacs-rspec
+ (package
+ (name "emacs-rspec")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pezra/rspec-mode/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j0a7ms5516nlg60qfyn730pfxys6acm0rgyxh5xfkpi6jafgpvw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/pezra/rspec-mode")
+ (synopsis "Provides a rspec mode for working with RSpec")
+ (description
+ "The Emacs RSpec mode provides keybindings for Ruby source files, e.g. to
+verify the spec associated with the current buffer, or entire project, as well
+as moving between the spec files, and coresponding code files.
+
+Also included are keybindings for spec files and Dired buffers, as well as
+snippets for yasnippet.")
+ (license license:gpl3+)))
+
(define-public emacs-smart-mode-line
(package
(name "emacs-smart-mode-line")