summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-15 11:04:45 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-15 11:08:02 +0100
commit83289a64ec5ea39320a006430e6781b0b22ee58a (patch)
tree737f0af7c8c240e51e1fdd6b4c824405eb7f3cbf /gnu
parent345a176a902556f899e8ae12adff9b6ed3fcb375 (diff)
gnu: python-lazy-loader: Update to 0.4.
This fixes python-scikit-image build failure as seen in <https://ci.guix.gnu.org/build/4357310/log/raw>. * gnu/packages/python-xyz.scm (python-lazy-loader): Update to 0.4. [native-inputs]: Remove python-pre-commit and python-pytest-cov; add python-numpy. Change-Id: Ie236fb30fd505fed1e07fd236403f9f456a37f29
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b295d780ab..da70779df5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21498,18 +21498,16 @@ inspection of types defined in the Python standard typing module.")
(define-public python-lazy-loader
(package
(name "python-lazy-loader")
- (version "0.3")
+ (version "0.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "lazy_loader" version))
(sha256
(base32
- "0dwghffnsjjf4pi4gwbl43rx04jmap375hdamafs5cpm6j78js1v"))))
+ "1lacaz292qxpgw6kxiirkx6sv9c5883nq4ssm3hs94cvb2153is7"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-pre-commit
- python-pytest
- python-pytest-cov))
+ (list python-numpy python-pytest))
(propagated-inputs
(list python-flit-core))
(home-page "https://scientific-python.org/specs/spec-0001/")