summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-27 10:18:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-27 10:18:46 +0200
commit842e491e2e798298246f3449b39d1e3f36fe7d1c (patch)
tree83115e705f895132dc158af3347feb62ec4a0a10 /gnu
parent0dffb145f09f135d6a22e00878da2ca9d650fdc5 (diff)
gnu: go-gopkg-in-yaml-v3: Skip tests on powerpc-linux.
* gnu/packages/golang.scm (go-gopkg-in-yaml-v3)[arguments]: Skip the tests when building for powerpc-linux. Change-Id: I68e3dfa274186ef8f20f85614ba941ea878d6b86
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7a9e081b4c..5e9211026b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5617,7 +5617,8 @@ values.")
(patches (search-patches "go-gopkg-in-yaml-v3-32bit.patch"))))
(build-system go-build-system)
(arguments
- '(#:import-path "gopkg.in/yaml.v3"))
+ `(#:tests? ,(not (target-ppc32?)) ; Test killed with quit: ran too long (11m0s).
+ #:import-path "gopkg.in/yaml.v3"))
(native-inputs
(list go-gopkg-in-check-v1))
(home-page "https://gopkg.in/yaml.v3")